KDE Gears 22.04 and Plasma 5.24.5 for Debian

I have updated my OBS builds to contain the new KDE Gears 22.04 as well as the last point release of KDE Plasma 5.24.5.

As usual, the packages are provided via my OBS builds. If you have used my packages till now, then you only need to change the apps2112 line to read apps2204. To give full details, I repeat (and update) instructions for all here: First of all, you need to add my OBS key say in /etc/apt/trusted.gpg.d/obs-npreining.asc and add a file /etc/apt/sources.lists.d/obs-npreining-kde.list, containing the following lines, replacing the DISTRIBUTION part with one of Debian_11 (for Bullseye), Debian_Testing, or Debian_Unstable:

deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other-deps/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/frameworks/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/plasma524/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/apps2204/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other/DISTRIBUTION/ ./

Some programs in the other group have been recompiled against the Gears 22.04 libraries.


PS: Considering that I don’t have a user-facing Debian computer anymore, all these packages are only tested by third parties and not by myself. Be aware!

PPS: Funny to read the Debian Social Contract, Point 4. Our priorities are our users and free software, obviously I care a lot about my users.

39 Responses

  1. Luc says:

    Big thanks again Norbert!!!! I updated my sources.list per your instructions and upgraded to Apps 2204. Everything looks great and is working.

    On the DFSG: is it envie and jealousy what is causing the Debian community behaviour?

  2. Dmitriy says:

    Thank you, Norbert! Unfortunately some packages can’t be upgraded. Apt wants to remove
    digikam digikam-private-libs kmymoney libkf5alarmcalendar5abi1 libkpmcore11 showfoto

    • Sorry I cannot test myself, but digikam etc should be recompiled against Gears 2204 and be installable. Which distribution (testing, stable, Sid) are you using?

    • Luc says:

      In my setup Digikam was installed smoothly. I think you need to fiddle with apt. Sometimes I encounter a situation like you describe, in which case I let it uninstall packages, and immediately after I install them again.

    • Dmitriy says:

      OK. I have come across the issue by playing a little bit with pinning (give a higher priority to your repo). After that apt has made upgrade without any problems. Thank you!

      • dantefff says:

        I’m in bullseye and in the same situation as you. Can you share how you pinned the repository. Thanks!

  3. Jerry says:

    There is an issue with the Debian 11 dependencies. Your polkit-kde-agent-1 has polkitd as a dependency, but that is not available in bullseye, just in testing and unstable. The standard Debian Bullseye polkit-kde-agent-1 pulls in policykit-1 instead. It appears Debian transitioned to the polkitd package for testing and unstable, but not for Bullseye.

  4. Michael Schaffner says:


    a huge thank you for doing this even without using it yourself!

    Two Problems on my side:

    1. polkit-kde-agent-1 isnt updated:

    $ sudo apt install polkit-kde-agent-1
    polkit-kde-agent-1 : Hängt ab von: polkitd ist aber nicht installierbar

    $ apt depends polkit-kde-agent-1=4:5.24.5-1~np1
    Hängt ab von:

    $ apt depends polkit-kde-agent-1=4:5.24.4-1~np1
    Hängt ab von: policykit-1

    2. cantor gets removed:

    $ sudo apt install cantor
    libcantorlibs28 : Beschädigt: cantor (< 4:22.04.0-2~) aber 4:22.04.0-1~np1 soll installiert werden

    $ apt depends libcantorlibs28=4:22.04.0-1~np1
    Beschädigt: cantor (<< 4:22.04.0-2~)

    • Thanks for the report, will check ASAP

    • polkit should be fixed with 5.24.5-1~np2
      cantor should be fixed with 4:22.04.0-1~np2
      Thanks for the report.

      • Michael Schaffner says:

        polkit is fixed, the cantor problem seems to still exist?!

        $ sudo apt install cantor libcantorlibs28
        libcantorlibs28 : Beschädigt: cantor (< 4:22.04.0-2~)

        Both packages are version 4:22.04.0-1~np2! Maybe some kind of typo in the Depends/Replaces/Breaks?

        Thanks again!

  5. Thank you. The upgrade was a breeze. 🙏🏼

  6. dpanter says:

    Thanks Norbert, update went swimmingly fine on Siduction. 🙂
    We miss ya buddy.

  7. Sedat says:

    Thanks for the kde-apps update to version 22.04.

    What happended to k3b and konqueror (and their libs)?

    root# dpkg -l | grep ’21\.12\.3′ | awk ‘{print $2}’ | sort

    libkf5alarmcalendar5abi1:amd64 package was removed on upgrade.

    Can you clarify?

  8. Dmitriy says:

    What has happened to korgac (korganizer reminder client)? It is missing in korganizer 4:22.04.0-1~np1 package.

  9. Bob says:

    Thanks for the updates!
    Calamares also needs a fix for bullseye. I backported it from unstable for my setup and it is installable now.

  10. Shmerl says:


    I tried to install Qt 5.15.3 packages from Debian experimental, but it seems to conflict with a bunch of 22.04.0 applications from your repo which it wants to remove in such scenario. Do they have some hard dependency on Qt 5.15.2?


    accountwizard akonadi-server akregator ark bluedevil breeze dolphin dragonplayer gwenview …

    • Yes, these packages use Qt internals and thus cannot be used with different versions. This is the same with the packages distributed within Debian itself. If you want to test a new Qt version, you need to rebuild these packages yourself.

  11. Sedat says:

    Looks like KDE apps version 22.04.1 from Norbert’s OBS Git now ships konqueror and k3b.
    Both apps start here.

    No version bump has:
    1. libkf5alarmcalendar5abi1:amd64
    2. libkf5alarmcalendar-data

  12. Luc says:

    Hi Norbert, thanks for including KDE Frameworks 5.94.0!

  13. Sedat says:

    Norbert, do your packages need a rebuild against OpenSSL-v3?

    Note: Debian/unstable is in a transition period (see [1]).

    [1] https://release.debian.org/transitions/html/auto-openssl.html

    • Probably at some point I need to recompile them. I hope that goes all without code changes, because otherwise it will be a huge pain to keep stable supported.

  14. Sedat says:

    Unsure, if this is a way to correctly determine the build-deps to libssl-dev:

    root# LC_ALL=C apt-rdepends –reverse libssl-dev | egrep -i ‘kde|kf5|qt’ | grep ‘Reverse Depends:’ | sort
    Reading package lists… Done
    Building dependency tree… Done
    Reading state information… Done
    Reverse Depends: libkf5kdelibs4support-dev (5.93.0-1)
    Reverse Depends: libpqtypes-dev (1.5.1-7)
    Reverse Depends: libvtk6-qt-dev (= 6.3.0+dfsg2-8.1+b1)
    Reverse Depends: libvtk7-qt-dev (= 7.1.1+dfsg2-10.1+b1)
    Reverse Depends: libvtk9-qt-dev (= 9.1.0+really9.1.0+dfsg2-3+b3)

    • Well, that looks not too bad. And the code uses just `libssl-dev` for B-D, so I just need to kick of a rebuild in due time, probably not immediately.

  15. Sedat says:

    Best is to wait the transition to openssl-v3 is done.
    You happen to know how to retrieve the information?

    ( I plan to update my selfmade LLVM toolchain and “be patient” might be a good strategy. )

  1. 2022/05/06

    […] Norbert Preining ☛ Norbert Preining: KDE Gears 22.04 and Plasma 5.24.5 for Debian […]

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>