KDE Gears 22.04 and Plasma 5.24.5 for Debian

I have updated my OBS builds to contain the new KDE Gears 22.04 as well as the last point release of KDE Plasma 5.24.5.

As usual, the packages are provided via my OBS builds. If you have used my packages till now, then you only need to change the apps2112 line to read apps2204. To give full details, I repeat (and update) instructions for all here: First of all, you need to add my OBS key say in /etc/apt/trusted.gpg.d/obs-npreining.asc and add a file /etc/apt/sources.lists.d/obs-npreining-kde.list, containing the following lines, replacing the DISTRIBUTION part with one of Debian_11 (for Bullseye), Debian_Testing, or Debian_Unstable:

deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other-deps/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/frameworks/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/plasma524/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/apps2204/DISTRIBUTION/ ./
deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other/DISTRIBUTION/ ./

Some programs in the other group have been recompiled against the Gears 22.04 libraries.

Enjoy!

PS: Considering that I don’t have a user-facing Debian computer anymore, all these packages are only tested by third parties and not by myself. Be aware!

PPS: Funny to read the Debian Social Contract, Point 4. Our priorities are our users and free software, obviously I care a lot about my users.

88 Responses

  1. Luc says:

    Big thanks again Norbert!!!! I updated my sources.list per your instructions and upgraded to Apps 2204. Everything looks great and is working.

    On the DFSG: is it envie and jealousy what is causing the Debian community behaviour?

  2. Dmitriy says:

    Thank you, Norbert! Unfortunately some packages can’t be upgraded. Apt wants to remove
    digikam digikam-private-libs kmymoney libkf5alarmcalendar5abi1 libkpmcore11 showfoto

    • Sorry I cannot test myself, but digikam etc should be recompiled against Gears 2204 and be installable. Which distribution (testing, stable, Sid) are you using?

    • Luc says:

      In my setup Digikam was installed smoothly. I think you need to fiddle with apt. Sometimes I encounter a situation like you describe, in which case I let it uninstall packages, and immediately after I install them again.

    • Dmitriy says:

      OK. I have come across the issue by playing a little bit with pinning (give a higher priority to your repo). After that apt has made upgrade without any problems. Thank you!

      • dantefff says:

        I’m in bullseye and in the same situation as you. Can you share how you pinned the repository. Thanks!

  3. Jerry says:

    There is an issue with the Debian 11 dependencies. Your polkit-kde-agent-1 has polkitd as a dependency, but that is not available in bullseye, just in testing and unstable. The standard Debian Bullseye polkit-kde-agent-1 pulls in policykit-1 instead. It appears Debian transitioned to the polkitd package for testing and unstable, but not for Bullseye.

  4. Michael Schaffner says:

    Hi,

    a huge thank you for doing this even without using it yourself!

    Two Problems on my side:

    1. polkit-kde-agent-1 isnt updated:

    $ sudo apt install polkit-kde-agent-1
    polkit-kde-agent-1 : Hängt ab von: polkitd ist aber nicht installierbar

    $ apt depends polkit-kde-agent-1=4:5.24.5-1~np1
    polkit-kde-agent-1
    Hängt ab von:

    $ apt depends polkit-kde-agent-1=4:5.24.4-1~np1
    polkit-kde-agent-1
    Hängt ab von: policykit-1

    2. cantor gets removed:

    $ sudo apt install cantor
    libcantorlibs28 : Beschädigt: cantor (< 4:22.04.0-2~) aber 4:22.04.0-1~np1 soll installiert werden

    $ apt depends libcantorlibs28=4:22.04.0-1~np1
    Beschädigt: cantor (<< 4:22.04.0-2~)

    • Thanks for the report, will check ASAP

    • polkit should be fixed with 5.24.5-1~np2
      cantor should be fixed with 4:22.04.0-1~np2
      Thanks for the report.

      • Michael Schaffner says:

        polkit is fixed, the cantor problem seems to still exist?!

        $ sudo apt install cantor libcantorlibs28
        libcantorlibs28 : Beschädigt: cantor (< 4:22.04.0-2~)

        Both packages are version 4:22.04.0-1~np2! Maybe some kind of typo in the Depends/Replaces/Breaks?

        Thanks again!

  5. Thank you. The upgrade was a breeze. 🙏🏼

  6. dpanter says:

    Thanks Norbert, update went swimmingly fine on Siduction. 🙂
    We miss ya buddy.

  7. Sedat says:

    Thanks for the kde-apps update to version 22.04.

    What happended to k3b and konqueror (and their libs)?

    root# dpkg -l | grep ’21\.12\.3′ | awk ‘{print $2}’ | sort
    k3b
    k3b-data
    k3b-i18n
    konq-plugins
    konqueror
    libk3b7:amd64
    libk3b7-extracodecs:amd64
    libkf5alarmcalendar-data
    libkf5konq6:amd64

    libkf5alarmcalendar5abi1:amd64 package was removed on upgrade.

    Can you clarify?

  8. Dmitriy says:

    Hello,
    What has happened to korgac (korganizer reminder client)? It is missing in korganizer 4:22.04.0-1~np1 package.

  9. Bob says:

    Thanks for the updates!
    Calamares also needs a fix for bullseye. I backported it from unstable for my setup and it is installable now.

  10. Shmerl says:

    Hi!

    I tried to install Qt 5.15.3 packages from Debian experimental, but it seems to conflict with a bunch of 22.04.0 applications from your repo which it wants to remove in such scenario. Do they have some hard dependency on Qt 5.15.2?

    Example:

    accountwizard akonadi-server akregator ark bluedevil breeze dolphin dragonplayer gwenview …

    • Yes, these packages use Qt internals and thus cannot be used with different versions. This is the same with the packages distributed within Debian itself. If you want to test a new Qt version, you need to rebuild these packages yourself.

  11. Sedat says:

    Looks like KDE apps version 22.04.1 from Norbert’s OBS Git now ships konqueror and k3b.
    Both apps start here.

    No version bump has:
    1. libkf5alarmcalendar5abi1:amd64
    2. libkf5alarmcalendar-data

  12. Luc says:

    Hi Norbert, thanks for including KDE Frameworks 5.94.0!

  13. Sedat says:

    Norbert, do your packages need a rebuild against OpenSSL-v3?

    Note: Debian/unstable is in a transition period (see [1]).

    [1] https://release.debian.org/transitions/html/auto-openssl.html

    • Probably at some point I need to recompile them. I hope that goes all without code changes, because otherwise it will be a huge pain to keep stable supported.

  14. Sedat says:

    Unsure, if this is a way to correctly determine the build-deps to libssl-dev:

    root# LC_ALL=C apt-rdepends –reverse libssl-dev | egrep -i ‘kde|kf5|qt’ | grep ‘Reverse Depends:’ | sort
    Reading package lists… Done
    Building dependency tree… Done
    Reading state information… Done
    Reverse Depends: libkf5kdelibs4support-dev (5.93.0-1)
    Reverse Depends: libpqtypes-dev (1.5.1-7)
    Reverse Depends: libvtk6-qt-dev (= 6.3.0+dfsg2-8.1+b1)
    Reverse Depends: libvtk7-qt-dev (= 7.1.1+dfsg2-10.1+b1)
    Reverse Depends: libvtk9-qt-dev (= 9.1.0+really9.1.0+dfsg2-3+b3)

    • Well, that looks not too bad. And the code uses just `libssl-dev` for B-D, so I just need to kick of a rebuild in due time, probably not immediately.

  15. Sedat says:

    Best is to wait the transition to openssl-v3 is done.
    You happen to know how to retrieve the information?

    ( I plan to update my selfmade LLVM toolchain and “be patient” might be a good strategy. )

  16. Helge says:

    Hello Norbert,
    once again kmymoney should be removed during the upgrade. Is there any solution for this?

    • What is the message/failing dependency?

      • Helge says:

        I think it’s because version 5.1.2-4 is installed.
        in your repo it is 5.1.2-3+np3.
        a downgrade to your version is also not possible because of several dependencies

      • Helge says:

        Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
        kmymoney-common libalkimia5-7 libcgi-fast-perl libcgi-pm-perl libclass-inspector-perl libclass-singleton-perl libcrypt-rc4-perl libdate-manip-perl libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl libdatetime-timezone-perl libdigest-perl-md5-perl libfcgi-bin libfcgi-perl libfcgi0ldbl libfile-sharedir-perl libfinance-quote-perl libgwengui-qt5-79 libhtml-selector-xpath-perl libhtml-tableextract-perl libhtml-tokeparser-simple-perl libhtml-treebuilder-libxml-perl libhtml-treebuilder-xpath-perl libjcode-pm-perl libjson-parse-perl libkf5alarmcalendar-data libkf5torrent6abi2 libkf5webkit5 libofx7 libokular5core9 libole-storage-lite-perl libosp5 libparse-recdescent-perl libspreadsheet-parseexcel-perl libspreadsheet-writeexcel-perl libspreadsheet-xlsx-perl libsqlcipher0 libtext-template-perl libtext-trim-perl libunicode-map-perl libuniversal-require-perl libweb-scraper-perl libyaml-libyaml-perl libyaml-perl
        Verwenden Sie »apt autoremove«, um sie zu entfernen.

        Die folgenden Pakete werden ENTFERNT:
        kmymoney libkf5alarmcalendar5abi1

        Die folgenden Pakete werden aktualisiert (Upgrade):
        accountwizard akonadi-backend-mysql akonadi-contacts-data akonadi-mime-data akonadi-server akonadiconsole akregator kaddressbook kaddressbook-data kde-config-mailtransport kdepim-addons kdepim-runtime kdepim-themeeditors kf5-messagelib-data
        kio-gdrive kio-ldap kleopatra kmail kmailtransport-akonadi knotes kontact korganizer libkf5akonadi-data libkf5akonadiagentbase5 libkf5akonadicalendar-data libkf5akonadicalendar5abi1 libkf5akonadicontact5 libkf5akonadicore5abi2 libkf5akonadimime5
        libkf5akonadinotes5 libkf5akonadiprivate5abi2 libkf5akonadisearch-bin libkf5akonadisearch-plugins libkf5akonadisearchcore5 libkf5akonadisearchdebug5 libkf5akonadisearchpim5 libkf5akonadisearchxapian5 libkf5akonadiwidgets5abi1 libkf5akonadixml5
        libkf5calendarsupport-data libkf5calendarsupport5abi1 libkf5calendarutils5 libkf5contacteditor5 libkf5eventviews5abi1 libkf5grantleetheme5 libkf5gravatar-data libkf5gravatar5abi2 libkf5identitymanagement5 libkf5imap5 libkf5incidenceeditor-data
        libkf5incidenceeditor5abi1 libkf5kmanagesieve5 libkf5kontactinterface-data libkf5kontactinterface5 libkf5ksieve-data libkf5ksieve5 libkf5ksieveui5 libkf5ldap5abi1 libkf5libkdepim-plugins libkf5libkdepim5 libkf5libkleo-data libkf5libkleo5
        libkf5mailcommon-data libkf5mailcommon5abi2 libkf5mailimporter5 libkf5mailimporterakonadi5 libkf5mailtransport-data libkf5mailtransport5 libkf5mailtransportakonadi5 libkf5mbox5 libkf5messagecomposer5abi1 libkf5messagecore5abi1
        libkf5messagelist5abi1 libkf5messageviewer5abi1 libkf5mime-data libkf5mime5abi1 libkf5mimetreeparser5abi1 libkf5pimcommon-data libkf5pimcommon5abi2 libkf5pimcommonakonadi5abi1 libkf5pimtextedit-data libkf5pimtextedit-plugins libkf5pimtextedit5abi2 libkf5templateparser5 libkf5tnef5 libkf5webengineviewer5abi1 libkpimaddressbookimportexport5 libkpimgapi-data libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapicore5abi1 libkpimgapidrive5 libkpimgapitasks5 libkpimimportwizard5 libkpimitinerary5
        libkpimpkpass5 libkpimsmtp5abi1 libsasl2-modules-kdexoauth2 mbox-importer pim-data-exporter pim-sieve-editor
        101 aktualisiert, 0 neu installiert, 2 zu entfernen und 0 nicht aktualisiert.

        • Ok, Debian has now newer package versions but old abi, I need to bump the version. Will do that later today.

          • Helge says:

            Hi Norbert, it would be great if you still do it. I would like to complete the upgrade.
            Thanks in advance.

          • Luc says:

            as of today 5.25 beta is available in Debian Experimental. maybe that helps your issue

          • Luc says:

            today debian uploaded 5.25 beta to experimental. maybe that solves your issue

          • Luc says:

            as of June 2, Plasma 5.25 beta is available in Debian Experimental, maybe this solves your issue

          • Helge says:

            Norbert, is there a chance you will do it?

          • Helge says:

            What you said.

            “Ok, Debian has now newer package versions but old abi, I need to bump the version. Will do that later today.”

            I still can’t upgrade because kmymoney is about to be removed.

          • Ahh, good point, forgot that. Just sent off kmymoney 5.1.2-4+np1 that should deal with it. Will need a bit of time to be rebuild, though.

          • Helge says:

            Very nice, that was quick. Upgrade was successful.
            Thank you again for your great work

      • Helge says:

        Hey Norbert,
        again it’s kmymoney that stops the show.
        During the dist-upgrade, kmymoney is the only package to be removed.
        kmymoney is so special?
        Here the output of apt dist-upgrade.

        Die folgenden Pakete werden ENTFERNT:
        kmymoney
        Die folgenden Pakete sind zurückgehalten worden:
        libllvm14
        Die folgenden Pakete werden aktualisiert (Upgrade):
        fcitx-frontend-qt5 frameworkintegration kde-style-qtcurve-qt5 kio kross ktexteditor-data ktexteditor-katepart kwayland-integration kwin-common kwin-x11 layer-shell-qt libcolorcorrect5 libkf5bookmarks-data libkf5bookmarks5 libkf5configwidgets-data
        libkf5configwidgets5 libkf5contacts-data libkf5contacts5 libkf5declarative-data libkf5declarative5 libkf5guiaddons-data libkf5guiaddons5 libkf5i18nlocaledata5 libkf5iconthemes-data libkf5iconthemes5 libkf5kcmutils-data libkf5kcmutils5
        libkf5kcmutilscore5 libkf5kdelibs4support-data libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5khtml-bin libkf5khtml-data libkf5khtml5 libkf5kiofilewidgets5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5krosscore5 libkf5krossui5
        libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5 libkf5notifyconfig-data libkf5notifyconfig5 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5plasma5 libkf5plasmaquick5 libkf5purpose-bin libkf5purpose5 libkf5runner5 libkf5style5
        libkf5texteditor-bin libkf5texteditor5 libkf5textwidgets-data libkf5textwidgets5 libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5webkit5 libkf5xmlgui-data libkf5xmlgui5 libkfontinst5 libkfontinstui5 libkpimitinerary5 libkwalletbackend5-5
        libkwineffects13 libkwinglutils13 libkwinxrenderutils13 libkworkspace5-5 liblayershellqtinterface5 libnotificationmanager1 libplasma-geolocation-interface5 libpyside2-py3-5.15 libqt5bluetooth5 libqt5bluetooth5-bin libqt5charts5 libqt5concurrent5
        libqt5core5a libqt5dbus5 libqt5designer5 libqt5gui5 libqt5location5 libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediagsttools5 libqt5multimediaquick5 libqt5multimediawidgets5 libqt5network5 libqt5networkauth5 libqt5opengl5
        libqt5opengl5-dev libqt5positioning5 libqt5positioningquick5 libqt5printsupport5 libqt5qml5 libqt5qmlmodels5 libqt5qmlworkerscript5 libqt5quick5 libqt5quickcontrols2-5 libqt5quickparticles5 libqt5quickshapes5 libqt5quicktemplates2-5
        libqt5quickwidgets5 libqt5remoteobjects5 libqt5script5 libqt5sensors5 libqt5serialport5 libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite libqt5svg5 libqt5test5 libqt5texttospeech5 libqt5virtualkeyboard5 libqt5waylandclient5 libqt5waylandcompositor5
        libqt5webchannel5 libqt5webengine-data libqt5webengine5 libqt5webenginecore5 libqt5webenginewidgets5 libqt5webkit5 libqt5websockets5 libqt5widgets5 libqt5x11extras5 libqt5xml5 libqt5xmlpatterns5 libtaskmanager6abi1 libweather-ion7 plasma-framework
        plasma-integration plasma-workspace python3-pyqt5 python3-pyqt5.qtmultimedia python3-pyqt5.qtopengl python3-pyqt5.qtpositioning python3-pyqt5.qtquick python3-pyqt5.qtremoteobjects python3-pyqt5.qtsensors python3-pyqt5.qtserialport
        python3-pyqt5.qtsql python3-pyqt5.qtsvg python3-pyqt5.qttexttospeech python3-pyqt5.qtwebchannel python3-pyqt5.qtwebkit python3-pyqt5.qtwebsockets python3-pyqt5.qtxmlpatterns qdbus-qt5 qml-module-org-kde-draganddrop qml-module-org-kde-kcm
        qml-module-org-kde-kconfig qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem qml-module-org-kde-newstuff
        qml-module-org-kde-purpose qml-module-org-kde-qqc2desktopstyle qml-module-qt-labs-platform qml-module-qt-labs-qmlmodels qml-module-qtbluetooth qml-module-qtgraphicaleffects qml-module-qtmultimedia qml-module-qtqml qml-module-qtquick-controls
        qml-module-qtquick-controls2 qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-particles2 qml-module-qtquick-privatewidgets qml-module-qtquick-shapes qml-module-qtquick-templates2 qml-module-qtquick-virtualkeyboard
        qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebengine qml-module-qtwebkit qt5-gtk-platformtheme qt5-image-formats-plugins qt5-qmake qt5-qmake-bin qtbase5-dev qtbase5-dev-tools qtspeech5-speechd-plugin qtwayland5

  17. João Pedro Sousa says:

    Hi Norbert! Any chance for KDE Plasma 5.25 Beta? 🙂

    • No, sorry. No beta versions. I am not even sure whether I go over 5.25 at all, considering that I am not running it anymore.

      • João Pedro Sousa says:

        Fair enough. Thank you anyway for all of your efforts so far!

      • luc says:

        sorry to read it, although i can understand. can this little community persuade you, how?

        • Packaging a new version of Plasma is a lot of work and, as I said, I don’t have a place to test anything. I’m not sure whether I want to invest the time.

          • Thiago Cangussu says:

            I know your time is valuable, but could you provide some guidance so other people can do what you are doing for us now?

          • luc says:

            Understood. For sure i’am willing to test.

  18. Markus says:

    Good day to you, i get an
    “EXPKEYSIG B8AC39B0876D807E home:npreining OBS Project ” error/warning
    Is the OBS now orphaned?

  19. Nabil Danial says:

    hi. ive been having this error message for a couple of hours now
    The following signatures were invalid: EXPKEYSIG B8AC39B0876D807E home:npreining OBS Project

    running the following command results in this error:
    sudo apt-key adv –keyserver keys.gnupg.net –recv-keys B8AC39B0876D807E
    Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
    Executing: /tmp/apt-key-gpghome.CEZtBBaD4b/gpg.1.sh –keyserver keys.gnupg.net –recv-keys B8AC39B0876D807E
    gpg: keyserver receive failed: Server indicated a failure

  20. midvok says:

    Thanks a lot Norbert, the update to KDE 5.24 installed perfectly for me.

    However, I still face one bug with the KDE apps on Debian 11, which was supposed to be fixed by KDE Frameworks 5.89 (https://www.reddit.com/r/kde/comments/s4yh35/how_to_completely_disable_all_menu_mnemonics_so_i/, https://invent.kde.org/frameworks/kwidgetsaddons/-/merge_requests/105).

    The bug causes that certain shortcuts like Alt+S do not work, because they are used by menu accelerators by default which causes the error “Ambiguous shortcut detected”. I believe it was fixed by KDE Frameworks 5.89 and it works fine for me on recent Manjaro, but I’m not able to make it working on Debian 11, no matter how I try to upgrade the KDE packages. I tested it with Dolphin and Krusader particularly. Please, any idea what could be the issue on Debian? Do these apps need to be recompiled again with the current KDE Frameworks?

    • midvok says:

      Finally, I made the shortcuts (Alt+S, etc) working after I created a new user account.

      Then, I discovered it was the file /home/{user}/.config/kdeglobals, which caused me the problems after KDE upgrade. So, I deleted it (to make it reset) and all shortcuts works fine also on my original account 🙂

  21. Markus says:

    Thank you for the updates

  22. Sedat says:

    With some mixed emotions I commented Norbert’s OBS repositories as he was removed from KDE uploaders. Furthermore, I do not think it makes much sense to include an APT repository where packages were not tested on the uploader’s machine.
    It’s like a cook not tasting his own meal creations.

    As for the records:
    Today (11-Jun-2022), I upgraded to KDE/Plasma from Debian/experimental AMD64 successfully.

    • Oh well, I guess it was only a question of time when the Qt/KDE team takes me out of the uploaders. In principle I still have upload rights for these packages, though 😉

      Anyway, I understand your feeling, and have warned about this, too. I regularly sync with the Debian packages, so there shouldn’t be a problem, and I provide builds for Debian/stable, which is done in Debian, so there is still an added value. But I agree that not being able to test it myself is a problem.

  23. Sedat says:

    Addendum:
    Norbert, thanks for all the love and time you invested in your APT repositories.

    root# LC_ALL=C wc -l KDE/KP-5-24-5.debian KDE/KP-5-24-90.debian
    98 KDE/KP-5-24-5.debian
    96 KDE/KP-5-24-90.debian
    194 total

    Missing packages in KDE/Plasma version 5.24.90 (5.25 beta):
    -libkwaylandserver5:amd64
    -libkwaylandserver-dev

    Did not iverstigate deeply as my KDE/Plasma starts a Wayland session…

  24. Mister00X says:

    Hi Norbert,
    first of all thank you for still maintaining these repos.

    It seems that libqt5qml5 in debian unstable was recently updated, which now causes libkpimitinerary5 and with it kdepim-addons to be removed on upgrading.
    I believe this is because libqt5qml5 now provides qtdeclarative-abi-5-15-4 while your libkpimitinerary5 package depends on qtdeclarative-abi-5-15-2. Do you think that you’re able to rebuild/fix your libkpimitinerary5 so that it can use the new libqt5qml5 package in debian?

  25. Sedat says:

    Just upgraded to QT version 5.15.4 and KDE/Plasma version 5.25.0 – partly (and manually) from unstable and experimental.

    As I do not use anymore Norbert’s OBS repos there exist still KDE/apps version 21.12.3:

    root# dpkg -l | grep 21.12.3 | wc -l
    41

    That stuff I am missing from Norbert.

  26. Debian user says:

    Hello Norbert, given you do not intend to provide plasma 5.25 in your repos, would you continue to provide updates to plasma 5.24 LTS, like 5.24.6 and beyond?

    • I have uploaded packages for 5.25 but they fail to build. I might find time to look into it

      For 5.24 LTS, that shouldn’t be a problem.

      • Where exactly do you keep your repositories ? I know OBS can allow multiple users to collaborate. Maybe, you could offload some of the efforts to interested people

        • Everything I do is what is on OBS, just check out the stuff with osc co home:npreining:debian-kde:plasma525 should give you the whole code for plasma 5.25, same for the other projects. I am more than happy to see other people contribute. It is really not that hard: if a build fails, check the logs for the reason, fix it, and commit the new package.

  27. Markus says:

    this error occurs:

    dpkg: Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-jJGERE/59-libkf5kcmutilscore5_5.95.0-1~np1_amd64.deb (–unpack):
    Versuch, »/usr/lib/x86_64-linux-gnu/libKF5KCMUtilsCore.so.5« zu überschreiben, welches auch in Paket libkf5kcmutils5:amd64 5.94.0-1~np1 ist

    sudo apt upgrade
    Paketlisten werden gelesen… Fertig
    Abhängigkeitsbaum wird aufgebaut… Fertig
    Statusinformationen werden eingelesen… Fertig
    Probieren Sie »apt –fix-broken install«, um dies zu korrigieren.
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    libkf5kcmutils5 : Hängt ab von: libkf5kcmutilscore5 (>= 5.94.0) ist aber nicht installiert
    E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt –fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

  28. Shmerl says:

    Hi!

    For some reason recent update (that bumps dependencies to newer Qt) tries to remove these packages:

    kdepim-addons libkpimitinerary5

    Are they incompatible or that’s expected?

  29. Birk says:

    Dear Norbert,

    thank you very, very much for your work and providing the world with Plasma 5.24 LTS and all the other recent KDE stuff for Debian 11 Bullseye!
    Because of you I completely replaced Kubuntu with Debian Bullseye together with Bullseye-backports and your Plasma 5.24 LTS with additional KDE stuff on my private computers last month. 🙂
    I hope you will continue to do so and that you will get some help from others. I would like to volunteer to do so personally, but I am just a humble retired computer technician with restricted knowledge – but if I could help you in any way, please let me know.

    After installation I had to additionally install vulkan-tools, mesa-utils and mesa-utils-extra to get information about graphics in Plasma “Info Centre” – are there some dependencies missing?

    Otherwise everthing has been fine and has been running perfectly, but since yesterday I ran into a problem while updating some packages from “deb https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other/Debian_11/ ./”:

    Fehl:1 https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other/Debian_11 ./ latte-dock 0.10.8-1~np2
    Datei hat eine unerwartete Größe (1328468 != 1328176). Eventuell läuft gerade eine Spiegel-Synchronisierung? [IP: 134.76.12.6 443]
    Hashes of expected file:
    – SHA256:33cae5256181bfcdcd9221bfb71125dabfcef3a60085a1603f827e9a4d06db25
    – SHA1:7baf02c36464bc788e37ee64e9a429b808a4e100 [weak]
    – MD5Sum:ace4bd09801729bcf1b6488eab3230a8 [weak]
    – Filesize:1328176 [weak]

    Anything I can do to fix this?

    And finally: You wrote above that you don’t have a computer with Debian yourself anymore…
    I could give you an older machine for testing in used but working condition (a Shuttle XPC DS61 V1.1) if you needed one. Or you could set up a donation button on this site, so if everyone gave you at least an Euro you certainly could buy a computer for running Debian.

    Dear Norbert, thanks again and feel free to contact me if in need.

    • Birk says:

      The issue with “latte-dock 0.10.8-1” is gone since yesterday night (with the “np3-version, I think).
      Everything installed/updated just fine, thank you!

  30. Shmerl says:

    Hi (not sure if my last comment went through).

    Is it expect that recent update in testing that already includes newer Qt tries to remove these?

    kdepim-addons libkpimitinerary5

    Are they obsoleted or there is some compat issue with these packages?

  1. 2022/05/06

    […] Norbert Preining ☛ Norbert Preining: KDE Gears 22.04 and Plasma 5.24.5 for Debian […]

Leave a Reply to Michael Schaffner Cancel reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>