KDE/Plasma for Debian – Update 2022/8

Monthly update on KDE/Plasma on Debian: Updates to Frameworks and KDE Gears

I have packaged KDE Gears 22.08 as well as the latest frameworks, and Plasma got a point release. The status is as follows (all for Debian/stable, testing, unstable:

  • Frameworks: 5.97
  • Gears: 22.08.0
  • Plasma 5.25: 5.25.4
  • Plasma 5.24 LTS: 5.24.6

I repeat (and update) instructions for all here, updated to use deb822 format (thanks to various comments on the blog here):

  • Get the key via
    curl -fsSL https://www.preining.info/obs-npreining.asc | sudo tee /usr/local/share/keyrings/obs-npreining.asc
    
  • Add the sources definition in /etc/apt/sources.lists.d/obs-npreining-kde.sources, replacing the DISTRIBUTION part with one of Debian_11 (for Bullseye), Debian_Testing, or Debian_Unstable:
    # deb822 source:
    # https://www.preining.info/blog/tag/kde/
    Types: deb
    URIs: 
     https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other-deps/DISTRIBUTION
     https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/frameworks/DISTRIBUTION
     https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/plasma525/DISTRIBUTION
     https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/apps2208/DISTRIBUTION
     https://download.opensuse.org/repositories/home:/npreining:/debian-kde:/other/DISTRIBUTION
    Suites: /
    Signed-By: /usr/local/share/keyrings/obs-npreining.asc
    Enabled: yes
    

Warnings/Todos:

  • Update of the other repository to compile against Gears 22.08
  • kopete and ktorrent don’t compile. If you can fix that, please let me know.

Enjoy!

Usual disclaimer: Considering that I don’t have a user-facing Debian computer anymore, all these packages are only tested by third parties and not by myself. Be aware!

36 Responses

  1. Luc says:

    Yep. I was able to install 2208. ‘aptitude upgrade’ did the job. Thanks!!!

  2. vincentxavier says:

    Hello,
    Thanks for your great work !

    Please, could you add kalendarac package and recompile digikam for a complete build with 22.08

    • I’m trying to compile digikam, but there are errors. I need to check the mailing lists for possible fixes.

      Kalendar is already in 22.08, what do you mean?

      • vincentxavier says:

        kalendarac is the reminder daemon. It comes from

        ❯ apt showsrc kalendarac
        Package: akonadi-calendar
        Binary: kalendarac, libkf5akonadicalendar-data, libkf5akonadicalendar-dev, libkf5akonadicalendar5abi1
        Version: 4:22.04.3-2

        • Yannick says:

          Hi Norbert, it’s your libkf5akonadicalendar-bin that is named kalendarac in Debian repository and that is a dependency of the kdepim meta package.

    • Synced the package renaming from Debian over to here.

  3. Anonymous says:

    kalendarac is the reminder dameon. It comes from
    “`
    ❯ apt showsrc kalendarac
    Package: akonadi-calendar
    Binary: kalendarac, libkf5akonadicalendar-data, libkf5akonadicalendar-dev, libkf5akonadicalendar5abi1
    Version: 4:22.04.3-2
    “`

  4. Thomas Florek says:

    Gears packages work fine in Debian unstable. digikam still missing, as Norbert posted above.
    Norbert, thank you very much!

    • digikam is now there, too.

      • vincentxavier says:

        Could you please update the package revision to supercedes debian one ? Or give a straightforward way to pin your repo.

        • It is one purpose that I keep version numbers below those of Debian, since those are the authoritative ones.

          Which package in particular are you concerned? And are you running sid or another suite?

          I can give a pinning code later on, but the easiest way is to pin on the origin and use the obs url

  5. Laurent M. says:

    Thanks (very much) for your work! An “up to date” environment on a stable system, it’s the perfect world…

  6. Jake says:

    Thank you so much for your great work!

    I am still using Plasma 5.24 on Debian 11 and have changed the line “apps2204” to “apps2208” in the sources.

    It worked fine, but the update aborted with an error message:

    Fehler traten auf beim Bearbeiten von:
    /tmp/apt-dpkg-install-Aql6h8/44-libk3b8-extracodecs_22.08.0-1~np1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Before this came:

    Vormals nicht ausgewähltes Paket libk3b8-extracodecs:amd64 wird gewählt.
    Vorbereitung zum Entpacken von …/44-libk3b8-extracodecs_22.08.0-1~np1_amd64.deb …
    Entpacken von libk3b8-extracodecs:amd64 (22.08.0-1~np1) …
    dpkg: Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-Aql6h8/44-libk3b8-extracodecs_22.08.0-1~np1_amd64.deb (–unpack):
    Versuch, »/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/videodvd.so« zu überschreiben, welches auch in Paket libk3b7-extracodecs:amd64 22.04.3-1~np1 ist

    After “apt update” and “apt dist-upgrade” again, the upgrade went through without errors.
    The package “libk3b8-extracodecs” is not present. “libk3b7-extracodecs” has been removed. “libk3b8” is installed.

  7. João Pedro Sousa says:

    Hi Norbert! Just to say thank you and that it’s great to see you back in the game. If you aren’t you should! If you don’t mind me saying, I believe that the best way to make a stand is to keep doing it as you do best! One man consistently doing a better and faster work than a whole dedicated team. Quite an achievement and a statement in itself! Disturbing for sure. The rest will come as a consequence over time I’m sure.

  8. Birk says:

    Dear Norbert,
    today I upgraded my Debian 11 Bullseye with Plasma 5.24.6 from Frameworks 5.96 to 5.97 and from Gears 22.04.3 to 22.08.
    Nearly everthing went smoothly, even KTorrent 22.08 seems to have installed and uses Frameworks 5.97…
    There is just one little thing: libkf5guiaddons-bin won’t update from 5.96 to 5.97, neither with apt upgrade nor with apt full-upgrade.
    When I try to install it explicitly with apt install over 200 packages will be removed…
    I guess it must be some kind of dependency issue?
    Thanks again and a lot for your work and have a nice day!

    • Birk says:

      Today I got the update from Frameworks 5.97 to 5.98 for my Debian 11 Bullseye with Plasma 5.24.6 – thank you for your continuing work!
      Everything updated just fine, unfortunately “libkf5guiaddons-bin” remains at version 5.96:
      “libkf5guiaddons-bin/unbekannt 5.98.0-1~np1 amd64 [aktualisierbar von: 5.96.0-1~np2]”
      Die folgenden Pakete sind zurückgehalten worden:
      libkf5guiaddons-bin
      It is the same behaviour as with the update from Frameworks 5.96 to 5.97…
      Any suggestions?

      • Not all packages were built, so you did a partial upgrade, not good. Now everything should be there.

        • Birk says:

          Indeed, there was another handful of updates today – and now every single one did update to Frameworks 5.97, including “the old” libkf5guiaddons-bin 5.96.0-1~np2.
          You are the best!

        • Birk says:

          … did update to Frameworks 5.98, of course (not 5.97).

  9. Shmerl says:

    Recent update to 5.25.5 made packages

    qml-module-org-kde-kcmutils
    qml-module-org-kde-syntaxhighlightin

    not required. I marked them manual for now.

    Was that intended? Also kalendarac seems not to be required while before it was.

  10. Felicia P says:

    Thanks for the ongoing updates! 👍 I really cannot imagine using Plasma on Debian without this repository.

  11. m4gr4th34 says:

    I tried this update, but discover is warning that it will remove a whole bunch of apps, including discover, dolphin, plasma-desktop. i’m guessing this is not a good time to do the update, or will i need to reinstall plasma-desktop again after update?

    • Some packages got built only recently, it should work now.

      • m4gr4th34 says:

        Thanks, but although 9 new packages show up (341 total), it still warns that plasma-desktop etc will be removed.

      • João Pedro Sousa says:

        I have the same issue. Something is not right. I have the same issue. I guess some dependencies issues will get some debian meta packages to be removed take a lot of packages with them. In my case it seems all plasma-* and the task-kde-desktop packages are to be removed. Not good. Full paste: https://pastebin.com/ti7uK1WP

        • Thomas Florek says:

          Confirm your findings.
          I succeded by first installing
          # apt install libkf5guiaddons-data libkf5guiaddons5
          afterwards
          # apt full-upgrade
          went through.
          The package
          libkf5guiaddons-bin
          could be purged after that
          Still do not know, why?

  12. Dreamgame says:

    Seem like something is missing. qtbase-abi-5-15-4 can not be found.

  1. 2022/08/24

    […] Norbert Preining ☛ KDE/Plasma for Debian – Update 2022/8 […]

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>